SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
skp.h File Reference

Interfaces for reading metadata from SketchUp files without loading the whole file. More...

#include <SketchUpAPI/common.h>
#include <SketchUpAPI/unicodestring.h>

Functions

enum SUResult SUSkpReadGuid (const char *file_path, SUStringRef *guid)
 Reads the GUID, globally unique identifier, for a model without opening the whole file. More...
 

Detailed Description

Interfaces for reading metadata from SketchUp files without loading the whole file.

Function Documentation

enum SUResult SUSkpReadGuid ( const char *  file_path,
SUStringRef guid 
)

Reads the GUID, globally unique identifier, for a model without opening the whole file.

Since
SketchUp 2021.0, API 9.0
See Also
SUModelGetGuid
SUComponentDefinitionGetGuid
Parameters
[in]file_pathThe model filepath to read from.
[out]guidThe guid string.
Returns