SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Macros Pages
Related Functions
SUCurveRef Struct Reference

References a curve. More...

#include <SketchUpAPI/model/curve.h>

Inherits SUEntityRef.

Inherited by SUArcCurveRef.

Related Functions

(Note that these are not member functions.)

SUEntityRef SUCurveToEntity (SUCurveRef curve)
 Converts from an SUCurveRef to an SUEntityRef. This is essentially an upcast operation. More...
 
SUCurveRef SUCurveFromEntity (SUEntityRef entity)
 Converts from an SUEntityRef to an SUCurveRef. This is essentially a downcast operation so the given SUEntityRef must be convertible to an SUCurveRef. More...
 
enum SUResult SUCurveCreateWithEdges (SUCurveRef *curve, const SUEdgeRef edges[], size_t len)
 Creates a curve object with the given array of edges that is not connected to any face object. The array of N edges is sorted such that for each edge in the range [0, N] the start position of each edge is the same as the end position of the previous edge in the array. Each element of the array of edges is subsequently associated with the created curve object and must not be deallocated via SUEdgeRelease(). More...
 
enum SUResult SUCurveRelease (SUCurveRef *curve)
 Releases a curve object and its associated edge objects. More...
 
enum SUResult SUCurveGetType (SUCurveRef curve, enum SUCurveType *type)
 Retrieves the curve type of a curve object. More...
 
enum SUResult SUCurveGetNumEdges (SUCurveRef curve, size_t *count)
 Retrieves the number of edges that belong to a curve object. More...
 
enum SUResult SUCurveGetEdges (SUCurveRef curve, size_t len, SUEdgeRef edges[], size_t *count)
 Retrieves the edges of a curve object. Provides access to all edges in the curve. The first edge is the first element of the edges array and the last edge is the last element if all edges were retrieved. More...
 
enum SUResult SUCurveIsPolygon (SUCurveRef curve, bool *is_curve)
 True if this edge was originally created by the polygon tool, otherwise false. More...
 

Detailed Description

References a curve.

Friends And Related Function Documentation

enum SUResult SUCurveCreateWithEdges ( SUCurveRef curve,
const SUEdgeRef  edges[],
size_t  len 
)
related

Creates a curve object with the given array of edges that is not connected to any face object. The array of N edges is sorted such that for each edge in the range [0, N] the start position of each edge is the same as the end position of the previous edge in the array. Each element of the array of edges is subsequently associated with the created curve object and must not be deallocated via SUEdgeRelease().

Parameters
curveThe curve object created.
edgesThe array of edge objects.
lenThe number of edge objects in the array.
Returns
SUCurveRef SUCurveFromEntity ( SUEntityRef  entity)
related

Converts from an SUEntityRef to an SUCurveRef. This is essentially a downcast operation so the given SUEntityRef must be convertible to an SUCurveRef.

Parameters
[in]entityThe given entity reference.
Returns
  • The converted SUCurveRef if the downcast operation succeeds
  • If not, the returned reference will be invalid
enum SUResult SUCurveGetEdges ( SUCurveRef  curve,
size_t  len,
SUEdgeRef  edges[],
size_t *  count 
)
related

Retrieves the edges of a curve object. Provides access to all edges in the curve. The first edge is the first element of the edges array and the last edge is the last element if all edges were retrieved.

Parameters
[in]curveThe curve object.
[in]lenThe number of edges to retrieve.
[out]edgesThe edges retrieved.
[out]countThe number of edges retrieved.
Returns
enum SUResult SUCurveGetNumEdges ( SUCurveRef  curve,
size_t *  count 
)
related

Retrieves the number of edges that belong to a curve object.

Parameters
[in]curveThe curve object.
[out]countThe number of edges.
Returns
enum SUResult SUCurveGetType ( SUCurveRef  curve,
enum SUCurveType type 
)
related

Retrieves the curve type of a curve object.

Parameters
[in]curveThe curve object.
[out]typeThe curve type retrieved.
Returns
enum SUResult SUCurveIsPolygon ( SUCurveRef  curve,
bool *  is_curve 
)
related

True if this edge was originally created by the polygon tool, otherwise false.

Since
SketchUp 2021.1, API 9.1
Parameters
[in]curve
[out]is_curveThe edges retrieved.
Returns
enum SUResult SUCurveRelease ( SUCurveRef curve)
related

Releases a curve object and its associated edge objects.

Parameters
curveThe curve object.
Returns
SUEntityRef SUCurveToEntity ( SUCurveRef  curve)
related

Converts from an SUCurveRef to an SUEntityRef. This is essentially an upcast operation.

Parameters
[in]curveThe given curve reference.
Returns
  • The converted SUEntityRef if curve is a valid object
  • If not, the returned reference will be invalid

The documentation for this struct was generated from the following files: