SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Related Functions
SUArcCurveRef Struct Reference

References an arccurve. More...

#include <SketchUpAPI/model/arccurve.h>

Inherits SUCurveRef.

Related Functions

(Note that these are not member functions.)

SUEntityRef SUArcCurveToEntity (SUArcCurveRef arccurve)
 Converts from an SUArcCurveRef to an SUEntityRef. This is essentially an upcast operation. More...
 
SUArcCurveRef SUArcCurveFromEntity (SUEntityRef entity)
 Converts from an SUEntityRef to an SUArcCurveRef. This is essentially a downcast operation so the given SUEntityRef must be convertible to an SUArcCurveRef. More...
 
SUCurveRef SUArcCurveToCurve (SUArcCurveRef arccurve)
 Converts from an SUArcCurveRef to an SUCurveRef. This is essentially an upcast operation. More...
 
SUArcCurveRef SUArcCurveFromCurve (SUCurveRef curve)
 Converts from an SUCurveRef to an SUArcCurveRef. This is essentially a downcast operation so the given SUCurveRef must be convertible to an SUArcCurveRef. More...
 
enum SUResult SUArcCurveCreate (SUArcCurveRef *arccurve, const struct SUPoint3D *center, const struct SUPoint3D *start_point, const struct SUPoint3D *end_point, const struct SUVector3D *normal, size_t num_edges)
 Creates an arccurve object. If the start and end points are the same a full circle will be generated. More...
 
enum SUResult SUArcCurveRelease (SUArcCurveRef *arccurve)
 Releases an arccurve object and its associated edge objects. More...
 
enum SUResult SUArcCurveGetRadius (SUArcCurveRef arccurve, double *radius)
 Retrieves the raduis. More...
 
enum SUResult SUArcCurveGetStartPoint (SUArcCurveRef arccurve, struct SUPoint3D *point)
 Retrieves the starting point. More...
 
enum SUResult SUArcCurveGetEndPoint (SUArcCurveRef arccurve, struct SUPoint3D *point)
 Retrieves the ending point. More...
 
enum SUResult SUArcCurveGetXAxis (SUArcCurveRef arccurve, struct SUVector3D *axis)
 Retrieves the x-axis. More...
 
enum SUResult SUArcCurveGetYAxis (SUArcCurveRef arccurve, struct SUVector3D *axis)
 Retrieves the y-axis. More...
 
enum SUResult SUArcCurveGetCenter (SUArcCurveRef arccurve, struct SUPoint3D *point)
 Retrieves the center point. More...
 
enum SUResult SUArcCurveGetNormal (SUArcCurveRef arccurve, struct SUVector3D *normal)
 Retrieves the normal. More...
 
enum SUResult SUArcCurveGetStartAngle (SUArcCurveRef arccurve, double *angle)
 Retrieves the start angle. More...
 
enum SUResult SUArcCurveGetEndAngle (SUArcCurveRef arccurve, double *angle)
 Retrieves the end angle. More...
 
enum SUResult SUArcCurveGetIsFullCircle (SUArcCurveRef arccurve, bool *is_full)
 

Detailed Description

References an arccurve.

Friends And Related Function Documentation

enum SUResult SUArcCurveCreate ( SUArcCurveRef arccurve,
const struct SUPoint3D center,
const struct SUPoint3D start_point,
const struct SUPoint3D end_point,
const struct SUVector3D normal,
size_t  num_edges 
)
related

Creates an arccurve object. If the start and end points are the same a full circle will be generated.

Since
SketchUp 2016, API 4.0
Parameters
[out]arccurveThe arccurve object created.
[in]centerThe point at the center of the arc.
[in]start_pointThe point at the start of the arc.
[in]end_pointThe point at the end of the arc.
[in]normalThe vector normal to the arc plane.
[in]num_edgesThe number of edges for the arc.
Returns
SUArcCurveRef SUArcCurveFromCurve ( SUCurveRef  curve)
related

Converts from an SUCurveRef to an SUArcCurveRef. This is essentially a downcast operation so the given SUCurveRef must be convertible to an SUArcCurveRef.

Since
SketchUp 2016, API 4.0
Parameters
[in]curveThe given curve reference.
Returns
  • The converted SUArcCurveRef if the downcast operation succeeds
  • If not, the returned reference will be invalid
SUArcCurveRef SUArcCurveFromEntity ( SUEntityRef  entity)
related

Converts from an SUEntityRef to an SUArcCurveRef. This is essentially a downcast operation so the given SUEntityRef must be convertible to an SUArcCurveRef.

Since
SketchUp 2016, API 4.0
Parameters
[in]entityThe given entity reference.
Returns
  • The converted SUArcCurveRef if the downcast operation succeeds
  • If not, the returned reference will be invalid
enum SUResult SUArcCurveGetCenter ( SUArcCurveRef  arccurve,
struct SUPoint3D point 
)
related

Retrieves the center point.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]pointThe arccurve center point.
Returns
enum SUResult SUArcCurveGetEndAngle ( SUArcCurveRef  arccurve,
double *  angle 
)
related

Retrieves the end angle.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]angleThe arccurve end angle.
Returns
enum SUResult SUArcCurveGetEndPoint ( SUArcCurveRef  arccurve,
struct SUPoint3D point 
)
related

Retrieves the ending point.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]pointThe arccurve ending point.
Returns
enum SUResult SUArcCurveGetIsFullCircle ( SUArcCurveRef  arccurve,
bool *  is_full 
)
related

a boolean indicating if the arccurve is a full circle.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]is_fullReturns true if the arccurve is a full corcle.
Returns
enum SUResult SUArcCurveGetNormal ( SUArcCurveRef  arccurve,
struct SUVector3D normal 
)
related

Retrieves the normal.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]normalThe arccurve normal vector.
Returns
enum SUResult SUArcCurveGetRadius ( SUArcCurveRef  arccurve,
double *  radius 
)
related

Retrieves the raduis.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]radiusThe arccurve radius.
Returns
enum SUResult SUArcCurveGetStartAngle ( SUArcCurveRef  arccurve,
double *  angle 
)
related

Retrieves the start angle.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]angleThe arccurve start angle.
Returns
enum SUResult SUArcCurveGetStartPoint ( SUArcCurveRef  arccurve,
struct SUPoint3D point 
)
related

Retrieves the starting point.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]pointThe arccurve starting point.
Returns
enum SUResult SUArcCurveGetXAxis ( SUArcCurveRef  arccurve,
struct SUVector3D axis 
)
related

Retrieves the x-axis.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]axisThe arccurve x-axis.
Returns
enum SUResult SUArcCurveGetYAxis ( SUArcCurveRef  arccurve,
struct SUVector3D axis 
)
related

Retrieves the y-axis.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe arccurve object.
[out]axisThe arccurve y-axis.
Returns
enum SUResult SUArcCurveRelease ( SUArcCurveRef arccurve)
related

Releases an arccurve object and its associated edge objects.

Since
SketchUp 2016, API 4.0
Parameters
[in,out]arccurveThe arccurve object.
Returns
SUCurveRef SUArcCurveToCurve ( SUArcCurveRef  arccurve)
related

Converts from an SUArcCurveRef to an SUCurveRef. This is essentially an upcast operation.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe given arccurve reference.
Returns
  • The converted SUCurveRef if arccurve is a valid arccurve object
  • If not, the returned reference will be invalid
SUEntityRef SUArcCurveToEntity ( SUArcCurveRef  arccurve)
related

Converts from an SUArcCurveRef to an SUEntityRef. This is essentially an upcast operation.

Since
SketchUp 2016, API 4.0
Parameters
[in]arccurveThe given arccurve reference.
Returns
  • The converted SUEntityRef if curve is a valid object
  • If not, the returned reference will be invalid

The documentation for this struct was generated from the following files: