SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
application.h File Reference

Interfaces for usage within the SketchUp application. More...

#include <SketchUpAPI/common.h>
#include <SketchUpAPI/model/defs.h>

Functions

enum SUResult SUApplicationGetActiveModel (SUModelRef *model)
 Gets a reference to the active model. The reference is owned by the SketchUp application and should not be released. More...
 

Detailed Description

Interfaces for usage within the SketchUp application.

Function Documentation

enum SUResult SUApplicationGetActiveModel ( SUModelRef model)

Gets a reference to the active model. The reference is owned by the SketchUp application and should not be released.

Since
SketchUp 2019.2, API 7.1
Parameters
[out]modelThe model object.
See Also
SUModelRef
Returns