SketchUp C API
|
Used to manage a Schema object. More...
#include <SketchUpAPI/model/schema.h>
Related Functions | |
(Note that these are not member functions.) | |
enum SUResult | SUSchemaGetSchemaType (SUSchemaRef schema_ref, const char *schema_type_name, SUSchemaTypeRef *schema_type_ref) |
Gets a schema type from a schema. More... | |
enum SUResult | SUSchemaGetSchemaName (SUSchemaRef schema_ref, SUStringRef *schema_name) |
Gets the name from a schema object. More... | |
Used to manage a Schema object.
|
related |
Gets the name from a schema object.
[in] | schema_ref | The schema object. |
[out] | schema_name | The name of the schema. |
schema_ref
is not a valid objectschema_name
is NULL
|
related |
Gets a schema type from a schema.
[in] | schema_ref | The schema object. |
[in] | schema_type_name | The name of the schema type to get. |
[out] | schema_type_ref | The schema type retrieved. |