SketchUp C API
|
Represents a 3D ray defined by a point and normal vector. More...
#include <SketchUpAPI/geometry.h>
Data Fields | |
struct SUPoint3D | point |
Origin of the ray. | |
struct SUVector3D | normal |
Direction of the ray. | |
Related Functions | |
(Note that these are not member functions.) | |
enum SUResult | SURay3DIsOn (const struct SURay3D *ray, const struct SUPoint3D *point, bool *is_on) |
Gets whether or not the point is on the ray. More... | |
enum SUResult | SURay3DDistanceTo (const struct SURay3D *ray, const struct SUPoint3D *point, double *distance) |
Gets the distance from the point to the ray. More... | |
enum SUResult | SURay3DProjectTo (const struct SURay3D *ray, const struct SUPoint3D *point, struct SUPoint3D *projected_point) |
Projects a point onto the ray. More... | |
Represents a 3D ray defined by a point and normal vector.
|
related |
Gets the distance from the point to the ray.
[in] | ray | The ray. |
[in] | point | The 3D point. |
[out] | distance | The distance between the ray and point. |
|
related |
Gets whether or not the point is on the ray.
[in] | ray | The ray. |
[in] | point | The 3D point. |
[out] | is_on | Whether or not the point is on the ray. |
|
related |
Projects a point onto the ray.
[in] | ray | The ray. |
[in] | point | The 3D point to project onto the ray. |
[out] | projected_point | The point resulting from the projection. |