SketchUp C API
|
Used to manage a Classifications object. More...
#include <SketchUpAPI/model/classifications.h>
Related Functions | |
(Note that these are not member functions.) | |
enum SUResult | SUClassificationsLoadSchema (SUClassificationsRef classifications, const char *schema_file_name) |
Loads a schema into a classifications object. More... | |
enum SUResult | SUClassificationsGetSchema (SUClassificationsRef classifications, const char *schema_name, SUSchemaRef *schema_ref) |
Gets a schema from a classifications object. More... | |
enum SUResult | SUClassificationsGetNumSchemas (SUClassificationsRef classifications, size_t *num_schemas) |
Gets the number of schemata from a classifications object. More... | |
enum SUResult | SUClassificationsGetSchemas (SUClassificationsRef classifications, size_t len, SUSchemaRef schemas[], size_t *count) |
Retrieves the schemas in the classifications object. More... | |
Used to manage a Classifications object.
|
related |
Gets the number of schemata from a classifications object.
[in] | classifications | The classifications object. |
[out] | num_schemas | The number of schemas in the classifications object. |
classifications
is not a valid objectnum_schemas
is NULL
|
related |
Gets a schema from a classifications object.
[in] | classifications | The classifications object. |
[in] | schema_name | The name of the schema to get. |
[out] | schema_ref | The schema retrieved. |
|
related |
Retrieves the schemas in the classifications object.
[in] | classifications | The classifications object. |
[in] | len | The number of schemas to retrieve. |
[out] | schemas | The schemas retrieved. |
[out] | count | The number of schemas retrieved. |
classifications
is not a valid objectschemas
or count
is NULLlen
is greater than 0, but no schemas were found in classifications
|
related |
Loads a schema into a classifications object.
[in] | classifications | The classificationss object. |
[in] | schema_file_name | The full path of the schema to load. |