|
(Note that these are not member functions.)
|
SUEntityRef | SUAxesToEntity (SUAxesRef axes) |
| Converts from an SUAxesRef to an SUEntityRef. This is essentially an upcast operation. More...
|
|
SUAxesRef | SUAxesFromEntity (SUEntityRef entity) |
| Converts from an SUEntityRef to an SUAxesRef. This is essentially a downcast operation so the given SUEntityRef must be convertible to an SUAxesRef. More...
|
|
SUDrawingElementRef | SUAxesToDrawingElement (SUAxesRef axes) |
| Converts from an SUAxesRef to an SUDrawingElementRef. This is essentially an upcast operation. More...
|
|
SUAxesRef | SUAxesFromDrawingElement (SUDrawingElementRef drawing_elem) |
| Converts from an SUDrawingElementRef to an SUAxesRef. This is essentially a downcast operation so the given element must be convertible to an SUAxesRef. More...
|
|
enum SUResult | SUAxesCreate (SUAxesRef *axes) |
| Creates a default constructed axes object. The axes object must be subsequently deallocated with SUAxesRelease() unless it is associated with a parent object. More...
|
|
enum SUResult | SUAxesCreateCustom (SUAxesRef *axes, const struct SUPoint3D *origin, const struct SUVector3D *xaxis, const struct SUVector3D *yaxis, const struct SUVector3D *zaxis) |
| Creates an axes object. The axes object must be subsequently deallocated with SUAxesRelease() unless it is associated with a parent object. More...
|
|
enum SUResult | SUAxesRelease (SUAxesRef *axes) |
| Releases aa axes object. The axes object must have been created with SUAxesCreate() and not subsequently associated with a parent object (e.g. SUEntitiesRef). More...
|
|
enum SUResult | SUAxesGetOrigin (SUAxesRef axes, struct SUPoint3D *origin) |
| Retrieves the origin point value, not a reference. More...
|
|
enum SUResult | SUAxesSetOrigin (SUAxesRef axes, const struct SUPoint3D *origin) |
| Sets the origin point value for the provided axes. More...
|
|
enum SUResult | SUAxesGetXAxis (SUAxesRef axes, struct SUVector3D *axis) |
| Retrieves the 1st axis vector value, not a reference. More...
|
|
enum SUResult | SUAxesGetYAxis (SUAxesRef axes, struct SUVector3D *axis) |
| Retrieves the 2nd axis vector value, not a reference. More...
|
|
enum SUResult | SUAxesGetZAxis (SUAxesRef axes, struct SUVector3D *axis) |
| Retrieves the 3rd axis vector value, not a reference. More...
|
|
enum SUResult | SUAxesSetAxesVecs (SUAxesRef axes, const struct SUVector3D *xaxis, const struct SUVector3D *yaxis, const struct SUVector3D *zaxis) |
| Sets the axes' vectors. Fails if vectors don't make an orthogonal axes. More...
|
|
enum SUResult | SUAxesGetTransform (SUAxesRef axes, struct SUTransformation *transform) |
| Retrieves a copy of the transformation. More...
|
|
enum SUResult | SUAxesGetPlane (SUAxesRef axes, struct SUPlane3D *plane) |
| Retrieves a copy of the plane. More...
|
|
enum SURefType | SUEntityGetType (SUEntityRef entity) |
| Returns the concrete type of the given entity. More...
|
|
enum SUResult | SUEntityGetID (SUEntityRef entity, int32_t *entity_id) |
| Retrieves the id of the entity. More...
|
|
enum SUResult | SUEntityGetPersistentID (SUEntityRef entity, int64_t *entity_pid) |
| Retrieves the persistent id of the entity. More...
|
|
enum SUResult | SUEntityGetNumAttributeDictionaries (SUEntityRef entity, size_t *count) |
| Retrieves the number of attribute dictionaries of an entity. More...
|
|
enum SUResult | SUEntityGetAttributeDictionaries (SUEntityRef entity, size_t len, SUAttributeDictionaryRef dictionaries[], size_t *count) |
| Retrieves the attribute dictionaries of an entity. More...
|
|
enum SUResult | SUEntityAddAttributeDictionary (SUEntityRef entity, SUAttributeDictionaryRef dictionary) |
| Adds the attribute dictionary to an entity. The given dictionary object must not belong to another entity. In other words, each dictionary should be added to one entity only. More...
|
|
enum SUResult | SUEntityGetAttributeDictionary (SUEntityRef entity, const char *name, SUAttributeDictionaryRef *dictionary) |
| Retrieves the attribute dictionary of an entity that has the given name. More...
|
|
enum SUResult | SUEntityGetModel (SUEntityRef entity, SUModelRef *model) |
| Retrieves the model object associated with the entity. More...
|
|
enum SUResult | SUEntityGetParentEntities (SUEntityRef entity, SUEntitiesRef *entities) |
| Retrieves the entities object which contains the entity. More...
|
|
An axes entity reference.
- Since
- SketchUp 2016, API 4.0