SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Data Structures | Typedefs | Enumerations
modelimporterplugin.h File Reference

Interfaces for SketchUpModelImporterInterface. More...

#include <string>
#include <SketchUpAPI/import_export/pluginprogresscallback.h>

Data Structures

struct  SketchUpModelImporterInterface
 A valid SketchUp "importer" plugin must support the following interface. See the SDK samples for an example. More...
 

Typedefs

typedef
SketchUpModelImporterInterface *(* 
GetSketchUpModelImporterInterfaceFunc )(void)
 

Enumerations

enum  SketchUpOptionsDialogResponse { IMPORTER_OPTIONS_UNAVAILABLE, IMPORTER_OPTIONS_CANCELLED, IMPORTER_OPTIONS_ACCEPTED }
 Return type of SketchUpOptionsDialogResponse::ShowOptionsDialog(). More...
 
enum  SketchUpModelImporterBehavior { IMPORT_MODEL_AT_ORIGIN, IMPORT_MODEL_AS_COMPONENT, IMPORT_MODEL_PRESERVE_ORIGIN, IMPORT_MODEL_RESET_ORIGIN_TO_BBOX_MIN }
 

Detailed Description

Interfaces for SketchUpModelImporterInterface.

Typedef Documentation

typedef SketchUpModelImporterInterface*(* GetSketchUpModelImporterInterfaceFunc)(void)

Each Windows DLL should export a function which returns the c++ interface.

Enumeration Type Documentation

Return type of GetImporterBehavior().

Enumerator
IMPORT_MODEL_AT_ORIGIN 

Preserves coordinates of the imported geometry.

IMPORT_MODEL_AS_COMPONENT 

New Sketchup 2017 import behaviors.

Model gets imported as a selected component with the move tool activated.

IMPORT_MODEL_PRESERVE_ORIGIN 

Same as IMPORT_MODEL_AT_ORIGIN.

IMPORT_MODEL_RESET_ORIGIN_TO_BBOX_MIN 

Translates the coordinates of the imported geometry such that the minimum point of the bounding box is at the origin.

Return type of SketchUpOptionsDialogResponse::ShowOptionsDialog().

Enumerator
IMPORTER_OPTIONS_UNAVAILABLE 

Importer options not available.

IMPORTER_OPTIONS_CANCELLED 

Importer options cancelled.

IMPORTER_OPTIONS_ACCEPTED 

Importer options accepted.