SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
model.h File Reference

Interfaces for SUModelRef for live access. More...

#include <SketchUpAPI/common.h>
#include <SketchUpAPI/application/overlay.h>

Functions

enum SUResult SUModelCreateOverlay (SUModelRef model, const struct SUOverlayCreateInfo *info, SUOverlayRef *overlay)
 Creates an overlay and adds it to the model. More...
 
enum SUResult SUModelReleaseOverlay (SUModelRef model, SUOverlayRef *overlay)
 Releases the overlay after removing it from the model. More...
 

Detailed Description

Interfaces for SUModelRef for live access.

Function Documentation

enum SUResult SUModelCreateOverlay ( SUModelRef  model,
const struct SUOverlayCreateInfo info,
SUOverlayRef overlay 
)

Creates an overlay and adds it to the model.

Since
SketchUp 2024, API 12.0
Parameters
[in]modelThe model object
[in]infoThe information needed to create the overlay object
[out]overlayThe created overlay object
Returns
enum SUResult SUModelReleaseOverlay ( SUModelRef  model,
SUOverlayRef overlay 
)

Releases the overlay after removing it from the model.

Parameters
[in]modelThe model object
[in,out]overlayThe overlay object to be released, will be set to NULL on return.
Since
SketchUp 2024, API 12.0
Returns