SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Related Functions
SULocationRef Struct Reference

References a type that contains location information of a model (e.g. latitude, longitude). More...

#include <SketchUpAPI/model/location.h>

Related Functions

(Note that these are not member functions.)

enum SUResult SULocationGetLatLong (SULocationRef location, double *latitude, double *longitude)
 Retrieves the latitude and longitude of a location object. More...
 
enum SUResult SULocationSetLatLong (SULocationRef location, double latitude, double longitude)
 Assigns the latitude and longitude values of a location object. More...
 
enum SUResult SULocationSetNorthAngle (SULocationRef location, double north_angle)
 Assigns the north angle values of a location object. More...
 

Detailed Description

References a type that contains location information of a model (e.g. latitude, longitude).

Friends And Related Function Documentation

enum SUResult SULocationGetLatLong ( SULocationRef  location,
double *  latitude,
double *  longitude 
)
related

Retrieves the latitude and longitude of a location object.

Parameters
[in]locationThe location object.
[out]latitudeThe latitude value retrieved.
[out]longitudeThe longitude value retrieved.
Returns
enum SUResult SULocationSetLatLong ( SULocationRef  location,
double  latitude,
double  longitude 
)
related

Assigns the latitude and longitude values of a location object.

Parameters
[in]locationThe location object.
[in]latitudeThe latitude value to assign.
[in]longitudeThe longitude value to assign.
Returns
enum SUResult SULocationSetNorthAngle ( SULocationRef  location,
double  north_angle 
)
related

Assigns the north angle values of a location object.

Parameters
[in]locationThe location object.
[in]north_angleThe north angle value to assign.
Returns

The documentation for this struct was generated from the following files: