SketchUp C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Related Functions
SULineStylesRef Struct Reference

Provides access to the different line style objects in the model. More...

#include <SketchUpAPI/model/line_styles.h>

Related Functions

(Note that these are not member functions.)

enum SUResult SULineStylesGetNumLineStyles (SULineStylesRef line_styles, size_t *count)
 Gets the number of line styles. More...
 
enum SUResult SULineStylesGetLineStyleNames (SULineStylesRef line_styles, size_t len, SUStringRef line_styles_provider_names[], size_t *count)
 Retrieves line styles associated with the line styles manager. More...
 
enum SUResult SULineStylesGetLineStyleByName (SULineStylesRef line_styles, const char *name, SULineStyleRef *line_style)
 Retrieves the line styles provider given a name. More...
 

Detailed Description

Provides access to the different line style objects in the model.

Friends And Related Function Documentation

enum SUResult SULineStylesGetLineStyleByName ( SULineStylesRef  line_styles,
const char *  name,
SULineStyleRef line_style 
)
related

Retrieves the line styles provider given a name.

Since
SketchUp 2019, API 7.0
Parameters
[in]line_stylesThe line_styles manager object.
[in]nameThe name of the line style object to get. Assumed to be UTF-8 encoded.
[out]line_styleThe line style object retrieved.
Returns
enum SUResult SULineStylesGetLineStyleNames ( SULineStylesRef  line_styles,
size_t  len,
SUStringRef  line_styles_provider_names[],
size_t *  count 
)
related

Retrieves line styles associated with the line styles manager.

Since
SketchUp 2019, API 7.0
Parameters
[in]line_stylesThe line_styles manager object.
[in]lenThe number of line style names to retrieve.
[out]line_styles_provider_namesThe line_style names retrieved.
[out]countThe number of line style names retrieved.
Returns
enum SUResult SULineStylesGetNumLineStyles ( SULineStylesRef  line_styles,
size_t *  count 
)
related

Gets the number of line styles.

Since
SketchUp 2019, API 7.0
Parameters
[in]line_stylesThe line_styles manager object.
[out]countThe number of line styles available.
Returns

The documentation for this struct was generated from the following files: