SketchUp C API
|
An instance path type that provides a wrapping of a data structure of component instances. More...
#include <SketchUpAPI/model/instancepath.h>
Related Functions | |
(Note that these are not member functions.) | |
enum SUResult | SUInstancePathCreate (SUInstancePathRef *instance_path) |
Creates an instance path object. More... | |
enum SUResult | SUInstancePathCreateCopy (SUInstancePathRef *instance_path, SUInstancePathRef source_path) |
Creates a copy of an instance path object. More... | |
enum SUResult | SUInstancePathRelease (SUInstancePathRef *instance_path) |
Releases an instance path object. More... | |
enum SUResult | SUInstancePathPushInstance (SUInstancePathRef instance_path, SUComponentInstanceRef component_instance) |
Pushes a SUComponentInstanceRef to an SUInstancePathRef. More... | |
enum SUResult | SUInstancePathPopInstance (SUInstancePathRef instance_path) |
Pops the last SUComponentInstanceRef from an SUInstancePathRef. More... | |
enum SUResult | SUInstancePathSetLeaf (SUInstancePathRef instance_path, SUEntityRef entity) |
Sets a SUEntityRef to an SUInstancePathRef. More... | |
enum SUResult | SUInstancePathGetPathDepth (SUInstancePathRef instance_path, size_t *depth) |
Gets a path depth for SUInstancePathRef. It only counts the component instances in the path, so the leaf node is not counted. More... | |
enum SUResult | SUInstancePathGetFullDepth (SUInstancePathRef instance_path, size_t *full_depth) |
Gets the full path depth (including the leaf) for SUInstancePathRef. More... | |
enum SUResult | SUInstancePathGetTransform (SUInstancePathRef instance_path, struct SUTransformation *transform) |
Gets the transform for SUInstancePathRef. More... | |
enum SUResult | SUInstancePathGetTransformAtDepth (SUInstancePathRef instance_path, size_t depth, struct SUTransformation *transform) |
Gets the transform up to depth level for SUInstancePathRef. More... | |
enum SUResult | SUInstancePathGetInstanceAtDepth (SUInstancePathRef instance_path, size_t depth, SUComponentInstanceRef *instance) |
Gets a component instance up to path depth level. More... | |
enum SUResult | SUInstancePathGetLeafAsEntity (SUInstancePathRef instance_path, SUEntityRef *entity) |
Gets a leaf from an instance path as an entity object. More... | |
enum SUResult | SUInstancePathGetLeaf (SUInstancePathRef instance_path, SUDrawingElementRef *drawing_element) |
Gets a leaf from an entity path as a drawing element object. More... | |
enum SUResult | SUInstancePathIsValid (SUInstancePathRef instance_path, bool *valid) |
Validates an instance path. More... | |
enum SUResult | SUInstancePathIsEmpty (SUInstancePathRef instance_path, bool *empty) |
Checks if an instance path is empty. More... | |
enum SUResult | SUInstancePathContains (SUInstancePathRef instance_path, SUEntityRef entity, bool *contains) |
Checks if instance path contains a particular entity. More... | |
enum SUResult | SUInstancePathGetPersistentID (SUInstancePathRef instance_path, SUStringRef *pid) |
Retrieves the full persistent id for a given instance path. More... | |
enum SUResult | SUInstancePathGetPersistentIDAtDepth (SUInstancePathRef instance_path, size_t depth, SUStringRef *pid) |
Retrieves the persistent id of an entity up to depth level in a given instance path. More... | |
An instance path type that provides a wrapping of a data structure of component instances.
|
related |
Checks if instance path contains a particular entity.
[in] | instance_path | The instance path object. |
[in] | entity | The entity object. |
[out] | contains | Whether the instance path contains the entity or not. |
|
related |
Creates an instance path object.
[out] | instance_path | The instance path object created. |
|
related |
Creates a copy of an instance path object.
[out] | instance_path | The copy of instance path object. |
[in] | source_path | The instance path to be copied. |
|
related |
Gets the full path depth (including the leaf) for SUInstancePathRef.
[in] | instance_path | The instance path object. |
[out] | full_depth | The depth of instance path object including the leaf (if it exists). |
|
related |
Gets a component instance up to path depth level.
[in] | instance_path | The instance path object. |
[in] | depth | The depth for getting drawing element up to. |
[out] | instance | The component instance from instance path. |
|
related |
Gets a leaf from an entity path as a drawing element object.
[in] | instance_path | The instance path object. |
[out] | drawing_element | The leaf from an instance path. |
|
related |
Gets a leaf from an instance path as an entity object.
[in] | instance_path | The instance path object. |
[out] | entity | The leaf from an instance path. |
|
related |
Gets a path depth for SUInstancePathRef. It only counts the component instances in the path, so the leaf node is not counted.
[in] | instance_path | The instance path object. |
[out] | depth | The depth of instance path object. |
|
related |
Retrieves the full persistent id for a given instance path.
[in] | instance_path | The instance path. |
[out] | pid | The persistent id. |
|
related |
Retrieves the persistent id of an entity up to depth level in a given instance path.
[in] | instance_path | The instance path. |
[in] | depth | The depth for getting persistent id up to. |
[out] | pid | The persistent id. |
|
related |
Gets the transform for SUInstancePathRef.
[in] | instance_path | The instance path object. |
[out] | transform | The transform from instance path. |
|
related |
Gets the transform up to depth level for SUInstancePathRef.
[in] | instance_path | The instance path object. |
[in] | depth | The depth for getting transforms up to. |
[out] | transform | The transform from instance path. |
|
related |
Checks if an instance path is empty.
[in] | instance_path | The instance path object. |
[out] | empty | Whether the instance path is empty or not. |
|
related |
Validates an instance path.
[in] | instance_path | The instance path object. |
[out] | valid | Whether the instance path is valid or not. |
|
related |
Pops the last SUComponentInstanceRef from an SUInstancePathRef.
[in] | instance_path | The instance path object. |
|
related |
Pushes a SUComponentInstanceRef to an SUInstancePathRef.
[in] | instance_path | The instance path object. |
[in] | component_instance | The component instance object. |
|
related |
Releases an instance path object.
[in] | instance_path | The instance path being released. |
|
related |
Sets a SUEntityRef to an SUInstancePathRef.
[in] | instance_path | The instance path object. |
[in] | entity | The entity to be set as a leaf in instance path or SU_INVALID if the leaf should be removed. |