LayOut C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Enumerations | Functions
style.h File Reference
#include <LayOutAPI/common.h>
#include <LayOutAPI/model/defs.h>
#include "entity.h"
#include <SketchUpAPI/color.h>

Go to the source code of this file.

Enumerations

enum  LOStrokeJoinStyle { LOStrokeJoinStyle_Miter = 0, LOStrokeJoinStyle_Round, LOStrokeJoinStyle_Bevel, LONumStrokeJoinStyles }
 Defines how to draw the connection between two segments of a path's stroke. More...
 
enum  LOStrokeCapStyle { LOStrokeCapStyle_Flat = 0, LOStrokeCapStyle_Round, LOStrokeCapStyle_Square, LONumStrokeCapStyles }
 Defines how to draw the end-caps of a path's stroke. More...
 
enum  LOStrokePattern {
  LOStrokePattern_Solid = 0, LOStrokePattern_Dash, LOStrokePattern_Dot, LOStrokePattern_DashDot,
  LOStrokePattern_DashDotDot, LOStrokePattern_DashSpace, LOStrokePattern_DashDotDotDot, LOStrokePattern_DashDashDot,
  LOStrokePattern_DashDashDotDot, LOStrokePattern_DashDashDotDotDot, LOStrokePattern_Center, LOStrokePattern_Phantom,
  LOStrokePattern_ShortDash, LONumStrokePatterns
}
 Defines the stippling pattern of a path's stroke. More...
 
enum  LOTextUnderline { LOTextUnderline_None = 0, LOTextUnderline_Single, LOTextUnderline_Double, LONumTextUnderlines }
 Defines underline styles for formatted text. More...
 
enum  LOTextElevation { LOTextElevation_Normal = 0, LOTextElevation_Superscript, LOTextElevation_Subscript, LONumTextElevations }
 Defines super/subscript options for formatted text. More...
 
enum  LOTextAlignment { LOTextAlignment_Left = 0, LOTextAlignment_Right, LOTextAlignment_Center, LONumTextAlignments }
 Defines left/right/center text alignment for formatted text. More...
 
enum  LOTextAnchor { LOTextAnchor_Top = 0, LOTextAnchor_Center, LOTextAnchor_Bottom, LONumTextAnchors }
 Defines top/center/bottom text anchoring for formatted text. More...
 
enum  LODimensionRotationAlignment {
  LODimensionRotationAlignment_Horizontal = 0, LODimensionRotationAlignment_Vertical, LODimensionRotationAlignment_Align, LODimensionRotationAlignment_Perpendicular,
  LONumDimensionRotationAlignments
}
 Represents how the dimension text is oriented on the page. More...
 
enum  LODimensionVerticalAlignment {
  LODimensionVerticalAlignment_Above = 0, LODimensionVerticalAlignment_Center, LODimensionVerticalAlignment_Below, LODimensionVerticalAlignment_Offset,
  LONumDimensionVerticalAlignments
}
 Represents how the dimension text is positioned. The position is relative to the dimension line. LODimensionVerticalAlignment_Offset indicates that the text box position is based on a custom offset. More...
 
enum  LODimensionUnits {
  LODimensionUnits_FractionalInches = 0, LODimensionUnits_ArchitecturalInches, LODimensionUnits_EngineeringFeet, LODimensionUnits_DecimalInches,
  LODimensionUnits_DecimalFeet, LODimensionUnits_DecimalMillimeters, LODimensionUnits_DecimalCentimeters, LODimensionUnits_DecimalMeters,
  LODimensionUnits_DecimalPoints, LODimensionUnits_Degrees, LODimensionUnits_Radians, LONumDimensionUnits
}
 Defines the different units formats that are available for linear and angular dimensions. More...
 
enum  LOArrowType {
  LOArrowType_None = 0, LOArrowType_FilledTriangle, LOArrowType_OpenTriangle, LOArrowType_FilledSkinnyTriangle,
  LOArrowType_OpenSkinnyTriangle, LOArrowType_OpenArrow90, LOArrowType_OpenArrow120, LOArrowType_FilledCircle,
  LOArrowType_OpenCircle, LOArrowType_FilledSquare, LOArrowType_OpenSquare, LOArrowType_FilledDiamond,
  LOArrowType_OpenDiamond, LOArrowType_Star, LOArrowType_T, LOArrowType_SlashRight,
  LOArrowType_SlashLeft, LOArrowType_Underrun, LOArrowType_Overrun, LONumArrowTypes
}
 Defines the arrowhead types available for a path entity. More...
 
enum  LOSubEntityType {
  LOSubEntityType_LabelLeaderLine = 0, LOSubEntityType_LabelText, LOSubEntityType_DimensionStartExtensionLine, LOSubEntityType_DimensionEndExtensionLine,
  LOSubEntityType_DimensionDimensionLine, LOSubEntityType_DimensionLeaderLine, LOSubEntityType_DimensionText, LONumSubEntityTypes
}
 Defines the types of sub entity that may have style attributes applied directly to them. More...
 

Functions

LO_RESULT LOStyleCreate (LOStyleRef *style)
 Creates a new empty style object. More...
 
LO_RESULT LOStyleRelease (LOStyleRef *style)
 Releases a style object. *style will be set to invalid by this function. More...
 
LO_RESULT LOStyleCopy (LOStyleRef src_style, LOStyleRef dst_style)
 Copies the style attributes from one style object to another. More...
 
LO_RESULT LOStyleGetStroked (LOStyleRef style, bool *is_stroked)
 Gets whether or not a style has a stroke. More...
 
LO_RESULT LOStyleSetStroked (LOStyleRef style, bool is_stroked)
 Sets whether or not a style has a stroke. More...
 
LO_RESULT LOStyleGetStrokeWidth (LOStyleRef style, double *stroke_width)
 Gets the stroke width of a style. More...
 
LO_RESULT LOStyleSetStrokeWidth (LOStyleRef style, double stroke_width)
 Sets the stroke width of a style. More...
 
LO_RESULT LOStyleGetStrokeColor (LOStyleRef style, SUColor *stroke_color)
 Gets the stroke color of a style. More...
 
LO_RESULT LOStyleSetStrokeColor (LOStyleRef style, SUColor stroke_color)
 Sets the stroke color of a style. More...
 
LO_RESULT LOStyleGetStrokeJoinStyle (LOStyleRef style, LOStrokeJoinStyle *join_type)
 Gets the stroke join style of a style. More...
 
LO_RESULT LOStyleSetStrokeJoinStyle (LOStyleRef style, LOStrokeJoinStyle join_type)
 Sets the stroke join style of a style. More...
 
LO_RESULT LOStyleGetStrokeCapStyle (LOStyleRef style, LOStrokeCapStyle *cap_type)
 Gets the stroke cap style of a style. More...
 
LO_RESULT LOStyleSetStrokeCapStyle (LOStyleRef style, LOStrokeCapStyle cap_type)
 Sets the stroke cap style of a style. More...
 
LO_RESULT LOStyleGetStrokePattern (LOStyleRef style, LOStrokePattern *stroke_pattern)
 Gets the stroke pattern of a style. More...
 
LO_RESULT LOStyleSetStrokePattern (LOStyleRef style, LOStrokePattern stroke_pattern)
 Sets the stroke pattern of a style. More...
 
LO_RESULT LOStyleGetStrokePatternScale (LOStyleRef style, double *pattern_scale)
 Gets the stroke pattern scale of a style. More...
 
LO_RESULT LOStyleSetStrokePatternScale (LOStyleRef style, double pattern_scale)
 Sets the stroke pattern scale of a style. More...
 
LO_RESULT LOStyleGetSolidFilled (LOStyleRef style, bool *solid_filled)
 Gets whether or not a style has a solid color fill. More...
 
LO_RESULT LOStyleSetSolidFilled (LOStyleRef style, bool solid_filled)
 Sets whether or not a style has a solid color fill. More...
 
LO_RESULT LOStyleGetSolidFillColor (LOStyleRef style, SUColor *fill_color)
 Gets the solid fill color of a style. More...
 
LO_RESULT LOStyleSetSolidFillColor (LOStyleRef style, SUColor fill_color)
 Sets the solid fill color of a style. More...
 
LO_RESULT LOStyleGetPatternFilled (LOStyleRef style, bool *pattern_filled)
 Gets whether there is a pattern fill or not of a style. More...
 
LO_RESULT LOStyleSetPatternFilled (LOStyleRef style, bool pattern_filled)
 Sets whether or not a style has a pattern fill. More...
 
LO_RESULT LOStyleGetPatternFillImagePath (LOStyleRef style, SUStringRef *image_path)
 Gets the pattern fill image path of a style. This is the file path for the pattern fill image file reference. More...
 
LO_RESULT LOStyleSetPatternFillImagePath (LOStyleRef style, const char *image_path)
 Sets the pattern fill image path of a style. This is the file path for the pattern fill image file reference. More...
 
LO_RESULT LOStyleGetPatternFillRotation (LOStyleRef style, double *rotation)
 Gets the rotation angle applied to the pattern fill of a style. More...
 
LO_RESULT LOStyleSetPatternFillRotation (LOStyleRef style, double rotation)
 Sets the rotation angle applied to the pattern fill of a style. More...
 
LO_RESULT LOStyleGetPatternFillScale (LOStyleRef style, double *scale)
 Gets the scale applied to the pattern fill of a style. More...
 
LO_RESULT LOStyleSetPatternFillScale (LOStyleRef style, double scale)
 Sets the scale applied to the pattern fill of a style. More...
 
LO_RESULT LOStyleGetPatternFillOrigin (LOStyleRef style, LOPoint2D *origin)
 Gets the origin for the pattern fill of a style. More...
 
LO_RESULT LOStyleSetPatternFillOrigin (LOStyleRef style, const LOPoint2D *origin)
 Sets the origin for the pattern fill of a style. More...
 
LO_RESULT LOStyleGetTextFontFamily (LOStyleRef style, SUStringRef *family)
 Gets the text font name of a style. More...
 
LO_RESULT LOStyleSetTextFontFamily (LOStyleRef style, const char *family)
 Sets the text font name of a style. More...
 
LO_RESULT LOStyleGetTextBold (LOStyleRef style, bool *is_bold)
 Gets whether or not text should be bold for a style. More...
 
LO_RESULT LOStyleSetTextBold (LOStyleRef style, bool is_bold)
 Sets whether or not text should be bold for a style. More...
 
LO_RESULT LOStyleGetTextItalic (LOStyleRef style, bool *is_italic)
 Gets whether or not text should be italicized for a style. More...
 
LO_RESULT LOStyleSetTextItalic (LOStyleRef style, bool is_italic)
 Sets whether or not text should be italicized for a style. More...
 
LO_RESULT LOStyleGetFontSize (LOStyleRef style, double *size_in_points)
 Gets the font size of a style. More...
 
LO_RESULT LOStyleSetFontSize (LOStyleRef style, double size_in_points)
 Sets the font size of a style. On Windows only, this font size will be truncated to an integer value. More...
 
LO_RESULT LOStyleGetTextColor (LOStyleRef style, SUColor *color)
 Gets the text color of a style. More...
 
LO_RESULT LOStyleSetTextColor (LOStyleRef style, SUColor color)
 Sets the text color of a style. More...
 
LO_RESULT LOStyleGetTextUnderline (LOStyleRef style, LOTextUnderline *underline_type)
 Gets the text underline type of a style. More...
 
LO_RESULT LOStyleSetTextUnderline (LOStyleRef style, LOTextUnderline underline_type)
 Sets the text underline type of a style. More...
 
LO_RESULT LOStyleGetTextElevation (LOStyleRef style, LOTextElevation *elevation_type)
 Gets the text elevation type (normal, superscript, or subscript) of a style. More...
 
LO_RESULT LOStyleSetTextElevation (LOStyleRef style, LOTextElevation elevation_type)
 Sets the text elevation type of a style. More...
 
LO_RESULT LOStyleGetTextAlignment (LOStyleRef style, LOTextAlignment *alignment_type)
 Gets the text alignment type of a style. More...
 
LO_RESULT LOStyleSetTextAlignment (LOStyleRef style, LOTextAlignment alignment_type)
 Sets the text alignment type of a style. More...
 
LO_RESULT LOStyleGetTextAnchor (LOStyleRef style, LOTextAnchor *anchor_type)
 Gets the text alignment type of a style. More...
 
LO_RESULT LOStyleSetTextAnchor (LOStyleRef style, LOTextAnchor anchor_type)
 Sets the text alignment type of a style. More...
 
LO_RESULT LOStyleGetDimensionRotationAlignment (LOStyleRef style, LODimensionRotationAlignment *alignment)
 Gets the dimension rotation alignment type of a style. More...
 
LO_RESULT LOStyleSetDimensionRotationAlignment (LOStyleRef style, LODimensionRotationAlignment alignment)
 Sets the dimension rotation alignment type of a style. More...
 
LO_RESULT LOStyleGetDimensionVerticalAlignment (LOStyleRef style, LODimensionVerticalAlignment *alignment)
 Gets the dimension vertical alignment setting of a style. More...
 
LO_RESULT LOStyleSetDimensionVerticalAlignment (LOStyleRef style, LODimensionVerticalAlignment alignment)
 Sets the dimension vertical alignment setting of a style. You can not set the alignment to LODimensionVerticalAlignment_Offset because it requires a relative vector for the position. More...
 
LO_RESULT LOStyleGetDimensionUnits (LOStyleRef style, LODimensionUnits *units, double *precision)
 Gets the dimension units and precision of a style. More...
 
LO_RESULT LOStyleSetDimensionUnits (LOStyleRef style, LODimensionUnits units, double precision)
 Sets the dimension units and precision of a style. More...
 
LO_RESULT LOStyleGetSuppressDimensionUnits (LOStyleRef style, bool *is_suppressed)
 Gets the dimension shall sppress unit display attribute of a style. More...
 
LO_RESULT LOStyleSetSuppressDimensionUnits (LOStyleRef style, bool is_suppressed)
 Sets the dimension shall sppress unit display attribute of a style. More...
 
LO_RESULT LOStrokePatternGetMaximumNumberOfWidths (size_t *num_widths)
 Gets the maximum number of widths that may be returned by LOStrokePatternGetWidths. Use this to determine the size of the array to pass to LOStrokePatternGetWidths. More...
 
LO_RESULT LOStrokePatternGetWidths (LOStrokePattern stroke_pattern, size_t len, double widths[], size_t *num_widths)
 Gets the widths of the alternating dashes and gaps for the given stroke pattern. These widths are expressed in paper space inches, and may be scaled (see LOStyleGetStrokePatternScale). Use LOStrokePatternGetMaximumNumberOfWidths to determine an adequate length for the widths array. More...
 
LO_RESULT LOStyleGetStartArrowType (LOStyleRef style, LOArrowType *type)
 Gets the the start arrow type of a style. More...
 
LO_RESULT LOStyleSetStartArrowType (LOStyleRef style, LOArrowType type)
 Sets the the start arrow type of a style. More...
 
LO_RESULT LOStyleGetStartArrowSize (LOStyleRef style, double *size)
 Gets the the start arrow size of a style. More...
 
LO_RESULT LOStyleSetStartArrowSize (LOStyleRef style, double size)
 Sets the the start arrow size of a style. More...
 
LO_RESULT LOStyleGetEndArrowType (LOStyleRef style, LOArrowType *type)
 Gets the end arrow type of a style. More...
 
LO_RESULT LOStyleSetEndArrowType (LOStyleRef style, LOArrowType type)
 Sets the end arrow type of a style. More...
 
LO_RESULT LOStyleGetEndArrowSize (LOStyleRef style, double *size)
 Gets the end arrow size of a style. More...
 
LO_RESULT LOStyleSetEndArrowSize (LOStyleRef style, double size)
 Sets the end arrow size of a style. More...
 
LO_RESULT LOStyleIsArrowTypeFilled (LOArrowType type, bool *filled)
 Gets whether or not an arrow type is filled in. More...
 
LO_RESULT LOStyleSetSubEntityStyle (LOStyleRef style, LOSubEntityType type, LOStyleRef sub_style)
 Adds a style to apply to an entity's sub-entity. This would be used to set the arrow head type for extension lines of a dimension, for example. More...
 
LO_RESULT LOStyleGetSubEntityStyle (LOStyleRef style, LOSubEntityType type, LOStyleRef *sub_style)
 Gets the style settings for a sub entity from a style. This would be used to get the current style of a dimension's text, for example. More...
 

Enumeration Type Documentation

Defines the arrowhead types available for a path entity.

Enumerator
LOArrowType_None 

No arrowhead.

LOArrowType_FilledTriangle 

Filled triangle arrowhead.

LOArrowType_OpenTriangle 

Non-filled triangle arrowhead.

LOArrowType_FilledSkinnyTriangle 

Filled skinny triangle arrowhead.

LOArrowType_OpenSkinnyTriangle 

Non-filled skinny triangle arrowhead.

LOArrowType_OpenArrow90 

90 degree open-sided arrowhead.

LOArrowType_OpenArrow120 

120 degree open-sided arrowhead.

LOArrowType_FilledCircle 

Filled circle arrowhead.

LOArrowType_OpenCircle 

Non-filled circle arrowhead.

LOArrowType_FilledSquare 

Filled square arrowhead.

LOArrowType_OpenSquare 

Non-filled square arrowhead.

LOArrowType_FilledDiamond 

Filled diamond arrowhead.

LOArrowType_OpenDiamond 

Non-filled diamond arrowhead.

LOArrowType_Star 

Star-shaped arrowhead.

LOArrowType_T 

T-shaped arrowhead.

LOArrowType_SlashRight 

Right slash arrowhead.

LOArrowType_SlashLeft 

Left slash arrowhead.

LOArrowType_Underrun 

Underrun arrowhead.

LOArrowType_Overrun 

Overrun arrowhead.

LONumArrowTypes 

Represents how the dimension text is oriented on the page.

Enumerator
LODimensionRotationAlignment_Horizontal 

Align the text horizontally.

LODimensionRotationAlignment_Vertical 

Align the text vertically.

LODimensionRotationAlignment_Align 

Align the text parallel to the dimension line.

LODimensionRotationAlignment_Perpendicular 

Align the text perpendicular to the dimension line.

LONumDimensionRotationAlignments 

Defines the different units formats that are available for linear and angular dimensions.

Enumerator
LODimensionUnits_FractionalInches 

60"

LODimensionUnits_ArchitecturalInches 

6-1/2"

LODimensionUnits_EngineeringFeet 

7.250'

LODimensionUnits_DecimalInches 

6.5"

LODimensionUnits_DecimalFeet 

0.54167'

LODimensionUnits_DecimalMillimeters 

165.1 mm

LODimensionUnits_DecimalCentimeters 

16.51 cm

LODimensionUnits_DecimalMeters 

1.651 m

LODimensionUnits_DecimalPoints 

468 pt

LODimensionUnits_Degrees 

21°

LODimensionUnits_Radians 

0.36 r

LONumDimensionUnits 

Represents how the dimension text is positioned. The position is relative to the dimension line. LODimensionVerticalAlignment_Offset indicates that the text box position is based on a custom offset.

Enumerator
LODimensionVerticalAlignment_Above 

Position the text above the dimension line.

LODimensionVerticalAlignment_Center 

Position the text on top of the dimension line.

LODimensionVerticalAlignment_Below 

Position the text under the dimension line.

LODimensionVerticalAlignment_Offset 

Position the text in an arbitrary location.

LONumDimensionVerticalAlignments 

Defines how to draw the end-caps of a path's stroke.

Enumerator
LOStrokeCapStyle_Flat 

The end caps will be flat.

LOStrokeCapStyle_Round 

The end caps will be round.

LOStrokeCapStyle_Square 

The end caps will be square.

LONumStrokeCapStyles 

Defines how to draw the connection between two segments of a path's stroke.

Enumerator
LOStrokeJoinStyle_Miter 

The corner between two segments will be pointed.

LOStrokeJoinStyle_Round 

The corner between two segments will be rounded.

LOStrokeJoinStyle_Bevel 

The corner between two segments will be flat.

LONumStrokeJoinStyles 

Defines the stippling pattern of a path's stroke.

Enumerator
LOStrokePattern_Solid 

Solid pattern.

LOStrokePattern_Dash 

Dashed pattern.

LOStrokePattern_Dot 

Dotted pattern.

LOStrokePattern_DashDot 

Repeating dash-dot pattern.

LOStrokePattern_DashDotDot 

Repeating dash-dot-dot pattern.

LOStrokePattern_DashSpace 

Deprecated in 2020.2. Use LOStrokePattern_Dash instead.

LOStrokePattern_DashDotDotDot 

Repeating dash-dot-dot-dot pattern.

LOStrokePattern_DashDashDot 

Repeating dash-dash-dot pattern.

LOStrokePattern_DashDashDotDot 

Repeating dash-dash-dot-dot pattern.

LOStrokePattern_DashDashDotDotDot 

Repeating dash-dash-dot-dot-dot pattern.

LOStrokePattern_Center 

Repeating center line type pattern.

LOStrokePattern_Phantom 

Repeating phantom line type pattern.

LOStrokePattern_ShortDash 

Repeating short dash pattern.

LONumStrokePatterns 

Defines the types of sub entity that may have style attributes applied directly to them.

Enumerator
LOSubEntityType_LabelLeaderLine 

A label's leader line object.

LOSubEntityType_LabelText 

A label's text object.

LOSubEntityType_DimensionStartExtensionLine 

A dimension's start extension line object.

LOSubEntityType_DimensionEndExtensionLine 

A dimension's end extension line object.

LOSubEntityType_DimensionDimensionLine 

A dimension's dimension line object.

LOSubEntityType_DimensionLeaderLine 

A dimension's leader line object.

LOSubEntityType_DimensionText 

A dimension's text object.

LONumSubEntityTypes 

Defines left/right/center text alignment for formatted text.

Enumerator
LOTextAlignment_Left 

Left-aligned text.

LOTextAlignment_Right 

Right-aligned text.

LOTextAlignment_Center 

Center-aligned text.

LONumTextAlignments 

Defines top/center/bottom text anchoring for formatted text.

Enumerator
LOTextAnchor_Top 

Top-anchored text.

LOTextAnchor_Center 

Center-anchored text.

LOTextAnchor_Bottom 

Bottom-anchored text.

LONumTextAnchors 

Defines super/subscript options for formatted text.

Enumerator
LOTextElevation_Normal 

Normal text.

LOTextElevation_Superscript 

Superscript text.

LOTextElevation_Subscript 

Subscript text.

LONumTextElevations 

Defines underline styles for formatted text.

Enumerator
LOTextUnderline_None 

No underline.

LOTextUnderline_Single 

Single underline.

LOTextUnderline_Double 

Double underline.

LONumTextUnderlines 

Function Documentation

LO_RESULT LOStrokePatternGetMaximumNumberOfWidths ( size_t *  num_widths)

Gets the maximum number of widths that may be returned by LOStrokePatternGetWidths. Use this to determine the size of the array to pass to LOStrokePatternGetWidths.

Parameters
[out]num_widthsThe maximum number of widths.
Returns
LO_RESULT LOStrokePatternGetWidths ( LOStrokePattern  stroke_pattern,
size_t  len,
double  widths[],
size_t *  num_widths 
)

Gets the widths of the alternating dashes and gaps for the given stroke pattern. These widths are expressed in paper space inches, and may be scaled (see LOStyleGetStrokePatternScale). Use LOStrokePatternGetMaximumNumberOfWidths to determine an adequate length for the widths array.

Parameters
[in]stroke_patternThe stroke pattern.
[in]lenThe maximum number of widths to return.
[out]widthsThe widths for the stroke pattern.
[out]num_widthsThe number of widths returned.
Returns
LO_RESULT LOStyleCopy ( LOStyleRef  src_style,
LOStyleRef  dst_style 
)

Copies the style attributes from one style object to another.

Parameters
[in]src_styleThe source style object.
[out]dst_styleThe destination style object.
Returns
LO_RESULT LOStyleCreate ( LOStyleRef style)

Creates a new empty style object.

Parameters
[out]styleThe style object.
Returns
LO_RESULT LOStyleGetDimensionRotationAlignment ( LOStyleRef  style,
LODimensionRotationAlignment alignment 
)

Gets the dimension rotation alignment type of a style.

Parameters
[in]styleThe style object.
[out]alignmentThe alignment.
Returns
LO_RESULT LOStyleGetDimensionUnits ( LOStyleRef  style,
LODimensionUnits units,
double *  precision 
)

Gets the dimension units and precision of a style.

Parameters
[in]styleThe style object.
[out]unitsThe units setting.
[out]precisionThe units precision. This is expressed as a value in the current units.
Returns
LO_RESULT LOStyleGetDimensionVerticalAlignment ( LOStyleRef  style,
LODimensionVerticalAlignment alignment 
)

Gets the dimension vertical alignment setting of a style.

Parameters
[in]styleThe style object.
[out]alignmentThe alignment.
Returns
LO_RESULT LOStyleGetEndArrowSize ( LOStyleRef  style,
double *  size 
)

Gets the end arrow size of a style.

Parameters
[in]styleThe style object.
[out]sizeThe arrow size.
Returns
LO_RESULT LOStyleGetEndArrowType ( LOStyleRef  style,
LOArrowType type 
)

Gets the end arrow type of a style.

Parameters
[in]styleThe style object.
[out]typeThe arrow type.
Returns
LO_RESULT LOStyleGetFontSize ( LOStyleRef  style,
double *  size_in_points 
)

Gets the font size of a style.

Parameters
[in]styleThe style object.
[out]size_in_pointsThe font size in points.
Returns
LO_RESULT LOStyleGetPatternFilled ( LOStyleRef  style,
bool *  pattern_filled 
)

Gets whether there is a pattern fill or not of a style.

Parameters
[in]styleThe style object.
[out]pattern_filledWhether there is a pattern fill or not.
Returns
LO_RESULT LOStyleGetPatternFillImagePath ( LOStyleRef  style,
SUStringRef image_path 
)

Gets the pattern fill image path of a style. This is the file path for the pattern fill image file reference.

Parameters
[in]styleThe style object.
[out]image_pathThe pattern fill image path.
Returns
LO_RESULT LOStyleGetPatternFillOrigin ( LOStyleRef  style,
LOPoint2D origin 
)

Gets the origin for the pattern fill of a style.

Parameters
[in]styleThe style object.
[out]originThe paper space origin for the pattern fill.
Returns
LO_RESULT LOStyleGetPatternFillRotation ( LOStyleRef  style,
double *  rotation 
)

Gets the rotation angle applied to the pattern fill of a style.

Parameters
[in]styleThe style object.
[out]rotationThe rotation angle applied to the pattern fill, in degrees.
Returns
LO_RESULT LOStyleGetPatternFillScale ( LOStyleRef  style,
double *  scale 
)

Gets the scale applied to the pattern fill of a style.

Parameters
[in]styleThe style object.
[out]scaleThe scale applied to the pattern fill.
Returns
LO_RESULT LOStyleGetSolidFillColor ( LOStyleRef  style,
SUColor fill_color 
)

Gets the solid fill color of a style.

Parameters
[in]styleThe style object.
[out]fill_colorThe solid fill color.
Returns
LO_RESULT LOStyleGetSolidFilled ( LOStyleRef  style,
bool *  solid_filled 
)

Gets whether or not a style has a solid color fill.

Parameters
[in]styleThe style object.
[out]solid_filledWhether there is a solid color fill or not.
Returns
LO_RESULT LOStyleGetStartArrowSize ( LOStyleRef  style,
double *  size 
)

Gets the the start arrow size of a style.

Parameters
[in]styleThe style object.
[out]sizeThe arrow size.
Returns
LO_RESULT LOStyleGetStartArrowType ( LOStyleRef  style,
LOArrowType type 
)

Gets the the start arrow type of a style.

Parameters
[in]styleThe style object.
[out]typeThe arrow type.
Returns
LO_RESULT LOStyleGetStrokeCapStyle ( LOStyleRef  style,
LOStrokeCapStyle cap_type 
)

Gets the stroke cap style of a style.

Parameters
[in]styleThe style object.
[out]cap_typeThe cap style.
Returns
LO_RESULT LOStyleGetStrokeColor ( LOStyleRef  style,
SUColor stroke_color 
)

Gets the stroke color of a style.

Parameters
[in]styleThe style object.
[out]stroke_colorThe stroke color.
Returns
LO_RESULT LOStyleGetStroked ( LOStyleRef  style,
bool *  is_stroked 
)

Gets whether or not a style has a stroke.

Parameters
[in]styleThe style object.
[out]is_strokedWhether there is a stroke or not.
Returns
LO_RESULT LOStyleGetStrokeJoinStyle ( LOStyleRef  style,
LOStrokeJoinStyle join_type 
)

Gets the stroke join style of a style.

Parameters
[in]styleThe style object.
[out]join_typeThe join style.
Returns
LO_RESULT LOStyleGetStrokePattern ( LOStyleRef  style,
LOStrokePattern stroke_pattern 
)

Gets the stroke pattern of a style.

Parameters
[in]styleThe style object.
[out]stroke_patternThe stroke pattern.
Returns
LO_RESULT LOStyleGetStrokePatternScale ( LOStyleRef  style,
double *  pattern_scale 
)

Gets the stroke pattern scale of a style.

Parameters
[in]styleThe style object.
[out]pattern_scaleThe stroke pattern scale.
Returns
LO_RESULT LOStyleGetStrokeWidth ( LOStyleRef  style,
double *  stroke_width 
)

Gets the stroke width of a style.

Parameters
[in]styleThe style object.
[out]stroke_widthThe stroke width.
Returns
LO_RESULT LOStyleGetSubEntityStyle ( LOStyleRef  style,
LOSubEntityType  type,
LOStyleRef sub_style 
)

Gets the style settings for a sub entity from a style. This would be used to get the current style of a dimension's text, for example.

Parameters
[in]styleThe style containing the sub entity style.
[in]typeThe type of sub entity the sub style is for.
[in]sub_styleThe sub entity style.
Returns
LO_RESULT LOStyleGetSuppressDimensionUnits ( LOStyleRef  style,
bool *  is_suppressed 
)

Gets the dimension shall sppress unit display attribute of a style.

Parameters
[in]styleThe style object.
[out]is_suppressedIs the dimension suppressing unit display.
Returns
LO_RESULT LOStyleGetTextAlignment ( LOStyleRef  style,
LOTextAlignment alignment_type 
)

Gets the text alignment type of a style.

Parameters
[in]styleThe style object.
[out]alignment_typeThe alignment type for text.
Returns
LO_RESULT LOStyleGetTextAnchor ( LOStyleRef  style,
LOTextAnchor anchor_type 
)

Gets the text alignment type of a style.

Parameters
[in]styleThe style object.
[out]anchor_typeThe anchor type for text.
Returns
LO_RESULT LOStyleGetTextBold ( LOStyleRef  style,
bool *  is_bold 
)

Gets whether or not text should be bold for a style.

Parameters
[in]styleThe style object.
[out]is_boldWhether text will be bolded or not.
Returns
LO_RESULT LOStyleGetTextColor ( LOStyleRef  style,
SUColor color 
)

Gets the text color of a style.

Parameters
[in]styleThe style object.
[out]colorThe color of the text.
Returns
LO_RESULT LOStyleGetTextElevation ( LOStyleRef  style,
LOTextElevation elevation_type 
)

Gets the text elevation type (normal, superscript, or subscript) of a style.

Parameters
[in]styleThe style object.
[out]elevation_typeThe text elevation type.
Returns
LO_RESULT LOStyleGetTextFontFamily ( LOStyleRef  style,
SUStringRef family 
)

Gets the text font name of a style.

Parameters
[in]styleThe style object.
[out]familyThe name of the font.
Returns
LO_RESULT LOStyleGetTextItalic ( LOStyleRef  style,
bool *  is_italic 
)

Gets whether or not text should be italicized for a style.

Parameters
[in]styleThe style object.
[out]is_italicWhether text will be italic or not.
Returns
LO_RESULT LOStyleGetTextUnderline ( LOStyleRef  style,
LOTextUnderline underline_type 
)

Gets the text underline type of a style.

Parameters
[in]styleThe style object.
[out]underline_typeThe type of underline for text.
Returns
LO_RESULT LOStyleIsArrowTypeFilled ( LOArrowType  type,
bool *  filled 
)

Gets whether or not an arrow type is filled in.

Parameters
[in]typeThe arrow type.
[out]filledWhether the arrow type is filled in or not.
Returns
LO_RESULT LOStyleRelease ( LOStyleRef style)

Releases a style object. *style will be set to invalid by this function.

Parameters
[in]styleThe style object.
Returns
LO_RESULT LOStyleSetDimensionRotationAlignment ( LOStyleRef  style,
LODimensionRotationAlignment  alignment 
)

Sets the dimension rotation alignment type of a style.

Parameters
[in]styleThe style object.
[in]alignmentThe new alignment to use.
Returns
LO_RESULT LOStyleSetDimensionUnits ( LOStyleRef  style,
LODimensionUnits  units,
double  precision 
)

Sets the dimension units and precision of a style.

Parameters
[in]styleThe style object.
[out]unitsThe units setting for the document.
[out]precisionThe units precision. This is expressed as a value in the specified units. LayOut only allows for a finite set of precision values for each units setting, so it will set the precision to the closest valid setting for the specified units. See the "Dimension Inspector" for a reference of the available precisions for each units setting.
Returns
LO_RESULT LOStyleSetDimensionVerticalAlignment ( LOStyleRef  style,
LODimensionVerticalAlignment  alignment 
)

Sets the dimension vertical alignment setting of a style. You can not set the alignment to LODimensionVerticalAlignment_Offset because it requires a relative vector for the position.

Parameters
[in]styleThe style object.
[in]alignmentThe new alignment to use.
Returns
LO_RESULT LOStyleSetEndArrowSize ( LOStyleRef  style,
double  size 
)

Sets the end arrow size of a style.

Parameters
[in]styleThe style object.
[in]sizeThe arrow size.
Returns
LO_RESULT LOStyleSetEndArrowType ( LOStyleRef  style,
LOArrowType  type 
)

Sets the end arrow type of a style.

Parameters
[in]styleThe style object.
[in]typeThe arrow type.
Returns
LO_RESULT LOStyleSetFontSize ( LOStyleRef  style,
double  size_in_points 
)

Sets the font size of a style. On Windows only, this font size will be truncated to an integer value.

Parameters
[in]styleThe style object.
[in]size_in_pointsThe font size in points.
Returns
LO_RESULT LOStyleSetPatternFilled ( LOStyleRef  style,
bool  pattern_filled 
)

Sets whether or not a style has a pattern fill.

Parameters
[in]styleThe style object.
[in]pattern_filledWhether there should be a pattern fill or not.
Returns
LO_RESULT LOStyleSetPatternFillImagePath ( LOStyleRef  style,
const char *  image_path 
)

Sets the pattern fill image path of a style. This is the file path for the pattern fill image file reference.

Parameters
[in]styleThe style object.
[in]image_pathThe pattern fill image path.
Returns
LO_RESULT LOStyleSetPatternFillOrigin ( LOStyleRef  style,
const LOPoint2D origin 
)

Sets the origin for the pattern fill of a style.

Parameters
[in]styleThe style object.
[out]originThe paper space origin for the pattern fill.
Returns
LO_RESULT LOStyleSetPatternFillRotation ( LOStyleRef  style,
double  rotation 
)

Sets the rotation angle applied to the pattern fill of a style.

Parameters
[in]styleThe style object.
[out]rotationThe rotation angle to apply to the pattern fill, in degrees.
Returns
LO_RESULT LOStyleSetPatternFillScale ( LOStyleRef  style,
double  scale 
)

Sets the scale applied to the pattern fill of a style.

Parameters
[in]styleThe style object.
[out]scaleThe scale to apply to the pattern fill.
Returns
LO_RESULT LOStyleSetSolidFillColor ( LOStyleRef  style,
SUColor  fill_color 
)

Sets the solid fill color of a style.

Parameters
[in]styleThe style object.
[in]fill_colorThe solid fill color.
Returns
LO_RESULT LOStyleSetSolidFilled ( LOStyleRef  style,
bool  solid_filled 
)

Sets whether or not a style has a solid color fill.

Parameters
[in]styleThe style object.
[in]solid_filledWhether there should be a solid color fill or not.
Returns
LO_RESULT LOStyleSetStartArrowSize ( LOStyleRef  style,
double  size 
)

Sets the the start arrow size of a style.

Parameters
[in]styleThe style object.
[in]sizeThe arrow size.
Returns
LO_RESULT LOStyleSetStartArrowType ( LOStyleRef  style,
LOArrowType  type 
)

Sets the the start arrow type of a style.

Parameters
[in]styleThe style object.
[in]typeThe arrow type.
Returns
LO_RESULT LOStyleSetStrokeCapStyle ( LOStyleRef  style,
LOStrokeCapStyle  cap_type 
)

Sets the stroke cap style of a style.

Parameters
[in]styleThe style object.
[in]cap_typeThe cap style.
Returns
LO_RESULT LOStyleSetStrokeColor ( LOStyleRef  style,
SUColor  stroke_color 
)

Sets the stroke color of a style.

Parameters
[in]styleThe style object.
[in]stroke_colorThe stroke color.
Returns
LO_RESULT LOStyleSetStroked ( LOStyleRef  style,
bool  is_stroked 
)

Sets whether or not a style has a stroke.

Parameters
[in]styleThe style object.
[in]is_strokedWhether there should be a stroke or not.
Returns
LO_RESULT LOStyleSetStrokeJoinStyle ( LOStyleRef  style,
LOStrokeJoinStyle  join_type 
)

Sets the stroke join style of a style.

Parameters
[in]styleThe style object.
[in]join_typeThe join style.
Returns
LO_RESULT LOStyleSetStrokePattern ( LOStyleRef  style,
LOStrokePattern  stroke_pattern 
)

Sets the stroke pattern of a style.

Parameters
[in]styleThe style object.
[in]stroke_patternThe stroke pattern.
Returns
LO_RESULT LOStyleSetStrokePatternScale ( LOStyleRef  style,
double  pattern_scale 
)

Sets the stroke pattern scale of a style.

Parameters
[in]styleThe style object.
[in]pattern_scaleThe stroke pattern scale.
Returns
LO_RESULT LOStyleSetStrokeWidth ( LOStyleRef  style,
double  stroke_width 
)

Sets the stroke width of a style.

Parameters
[in]styleThe style object.
[in]stroke_widthThe stroke width.
Returns
LO_RESULT LOStyleSetSubEntityStyle ( LOStyleRef  style,
LOSubEntityType  type,
LOStyleRef  sub_style 
)

Adds a style to apply to an entity's sub-entity. This would be used to set the arrow head type for extension lines of a dimension, for example.

Parameters
[in]styleThe style to contain the sub entity style.
[in]typeThe type of sub entity the sub style is for.
[in]sub_styleThe style to set as a sub entity style.
Returns
LO_RESULT LOStyleSetSuppressDimensionUnits ( LOStyleRef  style,
bool  is_suppressed 
)

Sets the dimension shall sppress unit display attribute of a style.

Parameters
[in]styleThe style object.
[in]is_suppressedIs the dimension suppressing unit display.
Returns
LO_RESULT LOStyleSetTextAlignment ( LOStyleRef  style,
LOTextAlignment  alignment_type 
)

Sets the text alignment type of a style.

Parameters
[in]styleThe style object.
[in]alignment_typeThe new text alignment type to use.
Returns
LO_RESULT LOStyleSetTextAnchor ( LOStyleRef  style,
LOTextAnchor  anchor_type 
)

Sets the text alignment type of a style.

Parameters
[in]styleThe style object.
[in]anchor_typeThe new text anchor type to use.
Returns
LO_RESULT LOStyleSetTextBold ( LOStyleRef  style,
bool  is_bold 
)

Sets whether or not text should be bold for a style.

Parameters
[in]styleThe style object.
[out]is_boldWhether text should be bolded or not.
Returns
LO_RESULT LOStyleSetTextColor ( LOStyleRef  style,
SUColor  color 
)

Sets the text color of a style.

Parameters
[in]styleThe style object.
[in]colorThe new text color to use.
Returns
LO_RESULT LOStyleSetTextElevation ( LOStyleRef  style,
LOTextElevation  elevation_type 
)

Sets the text elevation type of a style.

Parameters
[in]styleThe style object.
[in]elevation_typeThe new text elevation type to use.
Returns
LO_RESULT LOStyleSetTextFontFamily ( LOStyleRef  style,
const char *  family 
)

Sets the text font name of a style.

Parameters
[in]styleThe style object.
[in]familyThe name of the new font to use.
Returns
LO_RESULT LOStyleSetTextItalic ( LOStyleRef  style,
bool  is_italic 
)

Sets whether or not text should be italicized for a style.

Parameters
[in]styleThe style object.
[out]is_italicWhether text should be italic or not.
Returns
LO_RESULT LOStyleSetTextUnderline ( LOStyleRef  style,
LOTextUnderline  underline_type 
)

Sets the text underline type of a style.

Parameters
[in]styleThe style object.
[out]underline_typeThe type of underline to use for text.
Returns