LayOut C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
LOLayerInstanceRef Struct Reference

References a layer instance. A layer instance provides access to the entities that are drawn on a given layer, as well as the draw order of those entities. Groups are not included in the list of entities associated with a layer instance, since the group hierarchy has no effect on entity draw order. Each page has one layer instance for each layer in the document. Non-shared layer instances are unique per page, while shared layer instances are shared across all pages of the document. More...

#include <layerinstance.h>

Detailed Description

References a layer instance. A layer instance provides access to the entities that are drawn on a given layer, as well as the draw order of those entities. Groups are not included in the list of entities associated with a layer instance, since the group hierarchy has no effect on entity draw order. Each page has one layer instance for each layer in the document. Non-shared layer instances are unique per page, while shared layer instances are shared across all pages of the document.


The documentation for this struct was generated from the following file: