LayOut C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
grid.h File Reference
#include <LayOutAPI/common.h>
#include <LayOutAPI/model/defs.h>
#include <SketchUpAPI/color.h>

Go to the source code of this file.

Functions

LO_RESULT LOGridGetMajorSpacing (LOGridRef grid, double *spacing)
 Gets the major space size of the grid. More...
 
LO_RESULT LOGridSetMajorSpacing (LOGridRef grid, double spacing)
 Sets the gap between major grid lines for the grid. More...
 
LO_RESULT LOGridGetMinorDivisions (LOGridRef grid, int *divisions)
 Gets the number of minor divisions of the grid. More...
 
LO_RESULT LOGridSetMinorDivisions (LOGridRef grid, int divisions)
 Sets the number of minor divisions for the grid. More...
 
LO_RESULT LOGridGetMajorColor (LOGridRef grid, SUColor *color)
 Gets the color for the major grid lines. More...
 
LO_RESULT LOGridSetMajorColor (LOGridRef grid, SUColor color)
 Sets the color for the major grid lines. More...
 
LO_RESULT LOGridGetMinorColor (LOGridRef grid, SUColor *color)
 Gets the color for the minor grid lines. More...
 
LO_RESULT LOGridSetMinorColor (LOGridRef grid, SUColor color)
 Sets the color for the minor grid lines. More...
 
LO_RESULT LOGridGetShow (LOGridRef grid, bool *show)
 Gets whether or not the grid is visible. More...
 
LO_RESULT LOGridSetShow (LOGridRef grid, bool show)
 Sets whether or not the grid is visible. More...
 
LO_RESULT LOGridGetShowMajor (LOGridRef grid, bool *show)
 Gets whether or not the major grid lines are visible. More...
 
LO_RESULT LOGridSetShowMajor (LOGridRef grid, bool show)
 Sets whether or not the major grid lines are visible. More...
 
LO_RESULT LOGridGetShowMinor (LOGridRef grid, bool *show)
 Gets whether or not the minor grid lines are visible. More...
 
LO_RESULT LOGridSetShowMinor (LOGridRef grid, bool show)
 Sets whether or not the minor grid lines are visible. More...
 
LO_RESULT LOGridGetPrint (LOGridRef grid, bool *print)
 Gets whether or not the grid will be printed. More...
 
LO_RESULT LOGridSetPrint (LOGridRef grid, bool print)
 Sets whether or not the grid is will be printed. More...
 
LO_RESULT LOGridGetInFront (LOGridRef grid, bool *in_front)
 Gets whether or not the grid is drawn on top of entities. More...
 
LO_RESULT LOGridSetInFront (LOGridRef grid, bool in_front)
 Sets whether or not the grid is drawn on top of entities. More...
 
LO_RESULT LOGridGetClipToMargins (LOGridRef grid, bool *clip)
 Gets whether or not the grid is clipped to the paper margins. More...
 
LO_RESULT LOGridSetClipToMargins (LOGridRef grid, bool clip)
 Sets whether or not the grid is clipped to the paper margins. More...
 

Function Documentation

LO_RESULT LOGridGetClipToMargins ( LOGridRef  grid,
bool *  clip 
)

Gets whether or not the grid is clipped to the paper margins.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[out]clipWhether or not the grid is on top of entities.
Returns
LO_RESULT LOGridGetInFront ( LOGridRef  grid,
bool *  in_front 
)

Gets whether or not the grid is drawn on top of entities.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[out]in_frontWhether or not the grid is on top of entities.
Returns
LO_RESULT LOGridGetMajorColor ( LOGridRef  grid,
SUColor color 
)

Gets the color for the major grid lines.

Parameters
[in]gridThe grid object.
[out]colorThe color of the major grid lines.
Returns
LO_RESULT LOGridGetMajorSpacing ( LOGridRef  grid,
double *  spacing 
)

Gets the major space size of the grid.

Parameters
[in]gridThe grid object.
[out]spacingThe spacing of the major divisions of the grid.
Returns
LO_RESULT LOGridGetMinorColor ( LOGridRef  grid,
SUColor color 
)

Gets the color for the minor grid lines.

Parameters
[in]gridThe grid object.
[out]colorThe color of the minor grid lines.
Returns
LO_RESULT LOGridGetMinorDivisions ( LOGridRef  grid,
int *  divisions 
)

Gets the number of minor divisions of the grid.

Parameters
[in]gridThe grid object.
[out]divisionsThe minor division count.
Returns
LO_RESULT LOGridGetPrint ( LOGridRef  grid,
bool *  print 
)

Gets whether or not the grid will be printed.

Parameters
[in]gridThe grid object.
[out]printWhether or not the grid will be printed.
Returns
LO_RESULT LOGridGetShow ( LOGridRef  grid,
bool *  show 
)

Gets whether or not the grid is visible.

Parameters
[in]gridThe grid object.
[out]showWhether or not the grid is visible.
Returns
LO_RESULT LOGridGetShowMajor ( LOGridRef  grid,
bool *  show 
)

Gets whether or not the major grid lines are visible.

Parameters
[in]gridThe grid object.
[out]showWhether or not the major grid lines are visible.
Returns
LO_RESULT LOGridGetShowMinor ( LOGridRef  grid,
bool *  show 
)

Gets whether or not the minor grid lines are visible.

Parameters
[in]gridThe grid object.
[out]showWhether or not the minor grid lines are visible.
Returns
LO_RESULT LOGridSetClipToMargins ( LOGridRef  grid,
bool  clip 
)

Sets whether or not the grid is clipped to the paper margins.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]clipWhether or not the grid is clipped to the paper margins.
Returns
LO_RESULT LOGridSetInFront ( LOGridRef  grid,
bool  in_front 
)

Sets whether or not the grid is drawn on top of entities.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]in_frontWhether or not the grid is on top of entities.
Returns
LO_RESULT LOGridSetMajorColor ( LOGridRef  grid,
SUColor  color 
)

Sets the color for the major grid lines.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]colorThe new color for the major grid lines.
Returns
LO_RESULT LOGridSetMajorSpacing ( LOGridRef  grid,
double  spacing 
)

Sets the gap between major grid lines for the grid.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]spacingThe number of minor grid lines to have between major grid lines. Must be positive.
Returns
LO_RESULT LOGridSetMinorColor ( LOGridRef  grid,
SUColor  color 
)

Sets the color for the minor grid lines.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]colorThe new color for the minor grid lines.
Returns
LO_RESULT LOGridSetMinorDivisions ( LOGridRef  grid,
int  divisions 
)

Sets the number of minor divisions for the grid.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]divisionsThe number of minor grid lines to have between major grid lines. Must not be negative.
Returns
LO_RESULT LOGridSetPrint ( LOGridRef  grid,
bool  print 
)

Sets whether or not the grid is will be printed.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]printWhether or not the grid will be printed.
Returns
LO_RESULT LOGridSetShow ( LOGridRef  grid,
bool  show 
)

Sets whether or not the grid is visible.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]showWhether or not the grid is visible.
Returns
LO_RESULT LOGridSetShowMajor ( LOGridRef  grid,
bool  show 
)

Sets whether or not the major grid lines are visible.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]showWhether or not the major grid lines are visible.
Returns
LO_RESULT LOGridSetShowMinor ( LOGridRef  grid,
bool  show 
)

Sets whether or not the minor grid lines are visible.

Since
LayOut 2020.1, API 5.1
Parameters
[in]gridThe grid object.
[in]showWhether or not the minor grid lines are visible.
Returns