LayOut C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
entityiterator.h File Reference
#include <LayOutAPI/common.h>
#include <LayOutAPI/model/defs.h>

Go to the source code of this file.

Functions

LO_RESULT LOEntityIteratorRelease (LOEntityIteratorRef *entity_iterator)
 Releases an entity iterator object. *entity_iterator will be set to invalid by this function. More...
 
LO_RESULT LOEntityIteratorNext (LOEntityIteratorRef entity_iterator, LOEntityRef *entity)
 Gets a reference to the current entity and increment the iterator. entity will be set to an invalid object upon reaching the end of the iterator. More...
 

Function Documentation

LO_RESULT LOEntityIteratorNext ( LOEntityIteratorRef  entity_iterator,
LOEntityRef entity 
)

Gets a reference to the current entity and increment the iterator. entity will be set to an invalid object upon reaching the end of the iterator.

Parameters
[in]entity_iteratorThe entity iterator object.
[out]entityThe entity object.
Returns
LO_RESULT LOEntityIteratorRelease ( LOEntityIteratorRef entity_iterator)

Releases an entity iterator object. *entity_iterator will be set to invalid by this function.

Parameters
[in]entity_iteratorThe entity iterator object.
Returns