LayOut C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
connectionpoint.h File Reference
#include <LayOutAPI/common.h>
#include <LayOutAPI/geometry/geometry.h>
#include <LayOutAPI/model/defs.h>

Go to the source code of this file.

Functions

LO_RESULT LOConnectionPointCreate (LOConnectionPointRef *connection_point, LOEntityRef entity, const LOPoint2D *point, double aperture)
 Creates a new connection point object for the given entity at the given 2D point. More...
 
LO_RESULT LOConnectionPointCreateFromPoint3D (LOConnectionPointRef *connection_point, LOSketchUpModelRef model, const LOPoint3D *point3d)
 Creates a new connection point object for the given SketchUp model entity at the given 3D point in model space. Note that connection points created via this function will have no persistent ID assigned to them, resulting in a connection point that does not update when geometry is modified. More...
 
LO_RESULT LOConnectionPointCreateFromPID (LOConnectionPointRef *connection_point, LOSketchUpModelRef model, const LOPoint3D *point3d, const char *persistent_id)
 Creates a new connection point object for the given SketchUp model entity at the given 3D point in model space. Note that connection points created via this function have a persistent ID assigned to them, resulting in a connection point that updates when the geometry is modified. More...
 
LO_RESULT LOConnectionPointRelease (LOConnectionPointRef *connection_point)
 Releases a connection point object. The object will be invalidated if releasing the last reference. More...
 

Function Documentation

LO_RESULT LOConnectionPointCreate ( LOConnectionPointRef connection_point,
LOEntityRef  entity,
const LOPoint2D point,
double  aperture 
)

Creates a new connection point object for the given entity at the given 2D point.

Parameters
[out]connection_pointThe connection point object.
[in]entityThe entity object.
[in]pointThe position of the connection point.
[in]apertureThe search radius to use when looking for geometry to connect to.
Returns
LO_RESULT LOConnectionPointCreateFromPID ( LOConnectionPointRef connection_point,
LOSketchUpModelRef  model,
const LOPoint3D point3d,
const char *  persistent_id 
)

Creates a new connection point object for the given SketchUp model entity at the given 3D point in model space. Note that connection points created via this function have a persistent ID assigned to them, resulting in a connection point that updates when the geometry is modified.

Note
Starting in LayOut 2020.1, API 5.1, SU_ERROR_NO_DATA will be returned if persistent_id isn't valid for the given model.
Since
LO 2017, API 2.0
Parameters
[out]connection_pointThe connection point object.
[in]modelThe SketchUp model object.
[in]point3dThe 3D position of the connection point in model.
[in]persistent_idThe PID of the entity.
Returns
LO_RESULT LOConnectionPointCreateFromPoint3D ( LOConnectionPointRef connection_point,
LOSketchUpModelRef  model,
const LOPoint3D point3d 
)

Creates a new connection point object for the given SketchUp model entity at the given 3D point in model space. Note that connection points created via this function will have no persistent ID assigned to them, resulting in a connection point that does not update when geometry is modified.

Parameters
[out]connection_pointThe connection point object.
[in]modelThe SketchUp model object.
[in]point3dThe 3D position of the connection point in model space.
Returns
LO_RESULT LOConnectionPointRelease ( LOConnectionPointRef connection_point)

Releases a connection point object. The object will be invalidated if releasing the last reference.

Parameters
[in]connection_pointThe connection point object.
Returns