LayOut C API
 All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Friends Macros Pages
Functions
application.h File Reference
#include <LayOutAPI/common.h>
#include <LayOutAPI/model/defs.h>

Go to the source code of this file.

Functions

LO_RESULT LOApplicationGetApplication (LOApplicationRef *app)
 Gets the application instance. More...
 
LO_RESULT LOApplicationGetActiveDocument (LOApplicationRef app, LODocumentRef *document)
 Gets a reference to the active document. More...
 
LO_RESULT LOApplicationGetVersion (LOApplicationRef app, SUStringRef *version)
 Gets the major/minor version number as a string. More...
 
LO_RESULT LOApplicationGetVersionNumber (LOApplicationRef app, unsigned int *version)
 Gets the major/minor version number as an unsigned integer. More...
 
LO_RESULT LOApplicationGetOnline (LOApplicationRef app, bool *is_online)
 Gets whether the application is connected to the internet. More...
 
LO_RESULT LOApplicationOpenDocument (LOApplicationRef app, const char *file_path, LODocumentRef *document)
 Opens the LayOut document located at the given file path. More...
 
LO_RESULT LOApplicationQuit (LOApplicationRef app)
 Quits the application. More...
 

Function Documentation

LO_RESULT LOApplicationGetActiveDocument ( LOApplicationRef  app,
LODocumentRef document 
)

Gets a reference to the active document.

Since
LayOut 2018, API 3.0
Parameters
[in]appThe application instance.
[out]documentThe active document.
Returns
LO_RESULT LOApplicationGetApplication ( LOApplicationRef app)

Gets the application instance.

Since
LayOut 2018, API 3.0
Parameters
[out]appThe application instance.
Returns
LO_RESULT LOApplicationGetOnline ( LOApplicationRef  app,
bool *  is_online 
)

Gets whether the application is connected to the internet.

Since
LayOut 2018, API 3.0
Parameters
[in]appThe application instance.
[out]is_onlineTrue if the application is connected to the internet.
Returns
LO_RESULT LOApplicationGetVersion ( LOApplicationRef  app,
SUStringRef version 
)

Gets the major/minor version number as a string.

Since
LayOut 2018, API 3.0
Parameters
[in]appThe application instance.
[out]versionThe current version of the application.
Returns
LO_RESULT LOApplicationGetVersionNumber ( LOApplicationRef  app,
unsigned int *  version 
)

Gets the major/minor version number as an unsigned integer.

Since
LayOut 2018, API 3.0
Parameters
[in]appThe application instance.
[out]versionThe current version of the application.
Returns
LO_RESULT LOApplicationOpenDocument ( LOApplicationRef  app,
const char *  file_path,
LODocumentRef document 
)

Opens the LayOut document located at the given file path.

Since
LayOut 2018, API 3.0
Parameters
[in]appThe application instance.
[in]file_pathThe full file path to the .layout document to open.
[out]documentA reference to the opened document if successful.
Returns
LO_RESULT LOApplicationQuit ( LOApplicationRef  app)

Quits the application.

Since
LayOut 2018, API 3.0
Parameters
[in]appThe application instance.
Returns